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History

: successor of a software from the National Institutes of
Health called (Pascal-based, Mac only, early 90's)

Developed by Wayne Rasband, started 1997

Public Domain — source code available

Java based — Win, Mac, Linux, ...

Macros & plug-ins
Huge potential, very active community

Technical design limitations
15 yrs. old, usability somewhat “aged”

— Imaged basically can do everything, it's just sometimes
very hard to find out how...
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History

from the technical / administrative view
Requires a Java runtime installed
Can update itself only
Java?
Plugins?
Shipped with small, generic set of Plugins & Macros

Distributions showed up to address this:
(MacBiophotonics) “IJ for Microscopy”
Plugin collection

Abandoned
Since 2007 Is the don't-worry, ready-to-run solution!

http://developer.imagej.net/history




IJI s ust maged — Batteries included

is an Imaged distribution intended for Life sciences:
JRE with Java3D included
Huge set of Plugins, e.g. LOCI Bio-Formats
Powerful update mechanism
Non-intrusive
Cares about Java, the Plugins, ...
Customizable
Extensive documentation
Easy to install
But: shares ImagedJ's limitations

Fidi is actively co-developed with to reduce redundant
work and share good ideas and mechanisms.
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ImageJ

Fidi

FiJi vs. Imaged continued

Generic image processing framework - unfocused
Single “lead” developer W.Rasband

Aimed for Life Sciences
Emphasis on Registration, Segmentation & Volume Data
Community development effort
Quality mechanisms for plugins

Interoperability & code checks

Proper documentation

Maintainers for plugins
Support for more additional languages: Python, Ruby, ...
Script editor to develop plugins and macros

—



Resources

“The Bible” - ImagedJ user's guide: http://rsbweb.nih.gov/ij/docs/gquide/

Imaged dokuwiki: http://imagejdocu.tudor.lu/

Imaged macros: http://imagej.nih.gov/ij/macros/

Imaged mailing list: http://rsb.info.nih.gov/ij/list.html

FiJi download: http://fiji.sc/wiki/index.php/Downloads

Fidi wiki containing documentation for plugins, tutorials, etc:
http://fiji.sc/wiki/



http://rsbweb.nih.gov/ij/docs/guide/
http://imagejdocu.tudor.lu/
http://imagej.nih.gov/ij/macros/
http://rsb.info.nih.gov/ij/list.html
http://fiji.sc/wiki/index.php/Downloads
http://fiji.sc/wiki/

FiJi — getting started

First installation on Windows:
Download from http://fiji.sc/
If possible, use 64bit version
Choose a writeable location
NOT “C:\Program Files\...” !
NOT on a network share (works, but slow!)
e.g. ‘D:\Tools\
Unzip
Start & run updater

— Do NOT use “Update
Imaged” (unless explicitly requested)
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Updating FiJi

Sometimes the updater has a problem, just delete
the folder “update” inside the Fiji folder.

E There is an update available for the Fiji Updater. Install now?

Mame Statusfiction

fiji-linux64 Update it In general, it is safe to just click on

lugins/3D_Blob_Segmentation.j: Update it T 3 .
blugine/3 Viewer.jor . Update it Apply” to install the updates

plugins/AnalyzeSkeleton .jar Update it (and new paCkageS).
plugins/Anisotropic_Diffusion_2D.jar Update it
plugins/Arrow .jar Update it

plugins/Auto_Threshold.jar Update it . . . .
plugins/BalloonSegmentation_.jar Install it More |nf0rmat|0n 1S prOVIded by the

plugins/BeanShell Interpreter. jar Update it * 2
plugins/Bug_Submitter-2.0.0-SNAPS... Update it Advanced MOde e

plugins/Colocalisation_Analysis.jar Update it
plugins/Colour_Deconvolution.jar Install it
plugins/CorrectBleach .jar Install it
plugins/Daltonize_.jar Uninstall it
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Updating FiJi - Advanced

x — O Imaged Updater

Search: |

View Options: |View all files

Please choose what you want to install/uninstall:

MName | Status/Action
scriptsfinstalllava3D.m Up-to-date
scripts/lsjava3Dinstalled.m Up-to-date
scripts/Matlab30viewerDemao 1.m Up-to-date
scripts/Matlab30ViewerDemo_2.m Up-to-date
scripts/Matlab30ViewerDemo_3.m
scripts/Matlab30viewerintroduction.m
scripts/Miji.m p-to-date
scripts/Miji_Test.m Up-to-date
scripts/Record Desktop.py Local-only
scripts/Record_Window.py Local-only
scripts/bfopen.m Up-to-date
images/icon-flat.png
images/icon.png

Release date:
09 Aug 2012

Description :
IUse this Matlab function to initialize MIJ

Authors:
Jacques Pecreaux, Johannes Schindelin

Category:
interaperahility

Dependency:
macros/listManagement.txt Jars/mij.jar
macrosftoclsets/Clear Custom Tools.txt e

macros/toolsets/Drawing Tools. txt Up-to-date
macros/toolsets/Lookup Tables.txt Up-to-date

luts/16_colors.lut Up-to-date

Update site:
Fiji

install/update: 1 (344.5kB)

Keep as-is Install Uninstall Apply changes Easy mode Cancel

Manage update sites | Show changes
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Image Types |

Digital Images are tables of intensities,
each element defining a local
brightness value.

Steps depend on the number of levels
used for quantization:
1 bit—>0o0r1— 2 steps

2 bit = 2"2 — 4 steps
8 bit = 28 — 256 steps
16 bit = 2*16 = 65536
32 bit = 2232 > 4 million

Special case “RGB” = 8 bit for each, Red
Green and Blue (24 bit overall)

Imaged / FiJi workshop
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Image Types Il

¥ — 01

Imaged's handling
of image-data evolved
over time

— Single (x,y)
— Stack (x,y,c) / (x,y,t)

— Hyperstack: 4D / 5D
multi-channel timelapse

multiple positions
not limited to just 3 channels

Imaged / FiJi workshop

7.35 pm (171x

«1-10 35 um (171x196);
15.13x17.35 um (171x196);
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Colors

Several ways of dealing with colors exist in ImageJ:

No additional information — greyscale intensities
Multi-channel with colors assigned

“color” mode

‘composite” mode
RGB colors are no separated channels!

For visualization, Imaged provides the option to assign pseudo-colors via
LUT (Look-Up-Tables) — see later.
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The user interface

O

File Edit Image Process  Analyze  Plugins  Window

Fijiflmage] 1.47d; Java 1.6.0_24 [64-bit]; 23ME of 8575MB (=1%)

The main window has three parts:

Menu bar
Tools
Status line
Imaged & Java version
Memory architecture & current usage
Pixel positions and intensities while hovering on images
Descriptions of toolbar entries

Niko Ehrenfeuchter
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Opening Images

Via Menu “File”
Open / Open Recent

TIFF, GIF, JPEG, PNG, DICOM, BMP, PGM, FITS
Import

Sequences, Text Images, URL's, AVI's, LUT's, ...

Drag And Drop (on main window)
Tries to guess the applicable reader (no choice)

Using the Bio-Formats library from the LOCI plugin collection:
File > Import > Bio-Formats (at the bottom)
Plugins > LOCI > Bio-Formats Importer

— Bio-Formats is the preferred way for most proprietary file-formats.
http://loci.wisc.edu/bio-formats/formats




=

Opening Images with Bio-Formats

O Bilo-Formats Import Options

Stack viewing

View stack with: Hyperstack

Stack arder:

Dataset organization

_|Group files with similar names
_Open files individually

_1Swap dimensions

W Open all series

¥ Concatenate series when compatible

_IStiteh tiles

Color options

Color mode: Cefault

Aautoscale

Metadata viewing

_IDisplay metadata

_|Display OME-XML metadata
_IDisplay ROls

Memory management

|

_ISpecify range for each series

_|Crop on import

Split into separate windows

_ISplit channels
_ISplit focal planes

_ISplit timepoints

Information

Color mode - Visualizes channels
according to the specified scheme.

Fossible choices are:

# Default - Display channels as closely
as possible to how they are stored in
the file.

# Composite - Open as a merged
composite image. Channels are
colorized according to metadata
present in the dataset (if any), or in
the following default order: 1=red,
Z=green, 3=blue, 4=gray, 5=cyan,
G=magenta, 7=vyellow.

# Colorized - Open with each channel
in a separate plane, colorized
according to metadata present in
the dataset (if any). or in the default
order (see Composite above).

a Grayscale - Open with each channel

i a cernarate nlane disnlared in

0K | Cancel|

Niko Ehrenfeuchter
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The image window

Header line showing information:
c:1/2 211/25; 21.78%21.78 um (400x400); 8-bit; 7.6MB C h anne | S

Slices
Calibration
e Bit-depth
C:1/2z11/25; 21.78x21.78 um

Size (in memory!)

(400x400); 8-bit; 7.6MB

' Sliders at the bottom to adjust:
Active channel
Z-slice
Timepoint

Status bar in main window shows
intensities of current channel.

T Niko Ehrenfeuchter
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The Toolbar

Selection Tools:
Right click: choose variant
Double click: properties
— select region(s) of interest

Ky | % » Oval selections

_|Elliptical selections
_|Selection Brush Tool

Text tool
Zoom & pan
Colorpicker

CECIALE

User-configurable toolsets

HE3

Niko Ehrenfeuchter
Imaging Core Facility
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Image calibration

If you plan to do measurements on your
Images, check the calibration!

File

Image > Show Info

m]

Edit

Info For blobs.gif

Font

Imaged / FiJi workshop

Channels (¢

centC
Slices (z): 1
1

Frames (th:

Mote: c*z* must equal 3

Unit of Length: pixe

[
Pixel Width: |1.0000

Pixel Height: [1.0000

Voxel Depth: (1.0000

Frame Intersal;
Qrigin (pixelsk
_IGlobal

Cancel

Image > Properties

Niko Ehrenfeuchter
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Display Settings

Use Image > Adjust > “Brightness /
Contrast” to set the display minimum
and maximum values.

— “Auto” allows for a minimal
saturation — usually sane setting for
MinirLm

- . o ‘,ﬁ human perception.

Maxirnurm

=== — These settings DO NOT alter your
‘ Fontrast data, except when using the “Apply”

Auto | Reset
e button.

Niko Ehrenfeuchter
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Color Modes

Use Image > Colors > Channels Tool to select the display mode and
change the assignment of colors to the individual channels.

¥ — 0O
£:2f3 (Green); 5121512 pixels; 8-bit; 768K
x-— 0

" ®x — 0O
1/3 (Red); 512x512 pixels; 8-bit; 768K

1/3 (Red); 512x512 pixels; B-bit; 768K

Composite — |

Eoww IR
Fiyimage

Color =i |

¥ Channel 1 C il A
¥ Channel 2 ¥ Chamnel]
v charrel s | Channel 2
| Channel 3

More = |

Mare »|

Niko Ehrenfeuchter
Imaging Core Facility

Imaged / FiJi workshop



22

Lookup Tables

LUT's are filters that are applied before o -
the image is displayed on the screen. 362x178 pixels; 8-bit; 63K
Useful to check for saturation
Emphasize special intensities
Take B&C settings into account!
Not available for RGB images.

Image > Lookup Tables
or
Directly from the Toolbar

Characteristics & Editor:

Image > Color > Show LUT
Image > Color > Edit LUT

Imaged / FiJi workshop
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Histogram

Analyze > Histogram

Shows intensities distribution.
use “Log” mode
honors LUT
Statistics
Interactive

= L=
B .
755

Count: 64436 Mim: 12
Mean: 141,189 Max: 199
StdDew: 27.418 Mode: 145 (B8452)

¥ — 0O DLODE
352x178 pixels; 8-bit; 63K

¥| Log ljue| sailsle

count=a7

Niko Ehrenfeuchter
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Measuring

Imaged provides plenty of information for
selected regions.

To measure, just press “m” and the selected
results will show up in a new window.

®x O

W ires W Mean gray value

_IStandard deviation _IModal gray value

W Min & max gray value  ICentroid

¥ — 0O
362x1 78 pixels: 8-bit; 63K

_|Center of mass _IPerimeter

— Types can be configured in
Results > Set Measurements

_|Bounding rectangle _IFit ellipse
_IShape descriptors _IFeret's diameter
_lIntegrated density _IMedian
_ISkewness _lKurtosis

— Can be Saved as tXt or Csv f| Ie _|Area fraction _IStack position
_ILimit to threshold _IDisplay label

Inwert ¥ coordinates Ul Scientific notation

_ladd to overlay

Fedirect to:  MNone

Decimal places (0-8): (3

(a4

[}

File Edit Font Results

s e]
.E'ULJ

T Niko Ehrenfeuchter
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Distance / Profile Plots

- ol el ] emoboryos.|pg

344%236 pixels; RGB; 317K

Analyze > Plot Profile shows the intensity
profile along a previously selected line.

E.g. useful to measure the diameter of an
object for parts above a certain intensity
only.

The Plot itself is again

an image where, so

measurements can be
used on it again.

200

Distance (pixels)

T Niko Ehrenfeuchter
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Thresholding

Simplest approach for segmentation:
Image > Adjust > Threshold
Choose variant, background and value
Result is a binary image

® — O

256x254 pixels; B-bit (invertin u els; S bit (inverting LUT); 64K

Default —1| Red | ' ‘

_IDark background _IStack histogram

Auto | Apply

Niko Ehrenfeuchter
Imaging Core Facility

26 Imaged / FidJi workshop



27

Local Thresholding

w10 ; ( C
2561254 pixels; B-bit; 64K

Cefault

=] | Red - |

_|Dark background _IStack histogram

Auto

Apply

Imaged / FiJi workshop

Image
> Adjust
> Auto Local Threshold

Auto Local Threshold 1.4

Method Tryall —

Radius 15

Special paramters ({if different from default)

Farameter 1 |0
Farameter 2 |0

W wWhite ohjects on black background

Thresholded result is always shown in white [233].

Cancel

Niko Ehrenfeuchter
Imaging Core Facility



Local Thresholding

Disp|ays results for all e pivels; B-bit; 411K
local thresholding
methods.

— Try various settings
until results are
good.

— Run again and
select the desired
method instead of
“a””.

28 Imaged / FidJi workshop

Niko Ehrenfeuchter
Imaging Core Facility



Analyze Particles

Analyze > Analyze Particles finds connected components in a
thresholded (binary) image.
Results and ROl Manager is shown

0001 -0015 Add [t] |

0002-0005 Up date |

0003-0014 — 9 C
Celete |

0005-0014 Rename...

0006-0016

00070022

0008-0028 Deselect

File Edit Font Results

Meassure

(I
[0 I el Oy =
Ll =t

L

Properties...

L nood

0010-0027

0011-0034 Flatten [F]

% Show All

=
N~ = 00 noLa |

o N Is

“3 s I

~

0o

.|_.,
s
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ROI Manager

Analyze > Tools > ROl Manager: provides possibilities to handle multiple
regions of interest, for example:
Edit, delete, label
Save, load to and from files
Reapply to another image
Measure

0001-0015 Add [t]

0002-0005

¥ — 0O 0003_001_4 L.lpdate O

556x254 P'“E‘| 8-bit: b4|= 0004-0011 % Edit Font Results
0005-0014 N
0006-0016 Rename... |JArea | ]Pm
0007-0022 Measure 433

0008-0028 185
Deselect

558
Lo}

@ 0010-0027 Froperties... || 434

L Flatten [F] | 477

285
More =
al
W Show All 278
¥ Labels 231
30 14" 200 l“S lr:.u

11501 [185.142 1126 [23)

171 207 16 il

< >
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Touching Objects

Use Process > Binary > Watershed to split touching objects in a binary
image. Analyze Particles has to be re-run afterwards.

Niko Ehrenfeuchter
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L ocated in Process > Filters

Filtering

X — 0O
256%254 pixels; 8-bit; 64K

Imaged / FiJi workshop

Gaussian Blur
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3D Viewer

File Edit View Add Landmarks Help

A,00x384,00 mm (256x256):
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File
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Usability

Plugins > Shortcuts > List Shortcuts...

Keyboard Shortcuts

Edit Font

Command
All
t Editor
ct First Lane

Imaged / FidJi workshop
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Usability

Undo limitations — just ONE step:
There used to be a “multi undo” option, unfortunately it doesn't
show up in recent FiJi / Imaged versions.
While generating a work flow for image analysis use the
“Duplicate” (Shift-D) command to work on a copy.

¥ 0O

Recent Commands:

While “playing” it is easy to get confused which Find Commands...
operations you used, especially when trying to  SqvisSyNms
reproduce an intermediate result. List Shortcuts...

— The "Recent commands” window update LOCI Plugins
shows them in reverse order. R Iv ot

Find Commands...

Channels Tool...
Rename...

List Shortcuts...
Duplicate...
Bio-Formats Importer
RGB Color

Niko Ehrenfeuchter
Imaging Core Facility

35 Imaged / FiJi workshop



36

Usability

The LOCI tools provide a “shortcut” window containing buttons for the
individual tools — very useful if you need to access them often in your
work flow.

Open the window in Plugins > LOCI > LOCI Plugins Shortcut Window

Bio-Formats Importer
Bio-Formats Exporter
Bio-Formats Remote Importer

Bio-Formats Windowless Importer

Bio-Formats Macro Extensions

Stack Slicer

Update LOCI Plug|n5
About LOCI Plugins

Niko Ehrenfeuchter
Imaging Core Facility
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Usability

Instead of navigating through the tedious menus, ImagedJ provides the
“Control Panel” which shows the complete menu structure in a
collapsable tree view — sub-menus stay open an can be undocked for
quick access.

Open it via Shift-Ctrl-U or Plugins > Utilities > Control Panel.

A very fast and handy way is to use the command finder. Just press “L”
on the keyboard and start typing right away:

m]

Type part of a command: |plot
3D Surface Plot

Extended Profile Plot

Plot Lanes

Plot Profile

Plot Z-axis Profile

Profile Plot Options...

Re-plot Lanes

Surface Plot...

[[] Show full information Close when running

37 Imaged / FiJi workshop
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Usability

A more sophisticated way to adjust ImageJ to your needs is provided by
the “ActionBar” Plugin that creates graphical toolbars with big icons:

While this is a very nice tool it unfortunately doesn't have a nice way to
create or modify the Action Bars — this requires manually editing the
definition text file of a bar.

Niko Ehrenfeuchter
Imaging Core Facility
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Hands-on session
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