Outline

Part I – The Basics

- ImageJ's history
- Technical details, FiJi
- The ImageJ user interface
  - Mem, options, pointer, tools & variants
- Basic ImageJ tools and features
  - B&C, histogram, threshold, measure, de-noise / smooth
- Short-cuts & Usability
  - Command Finder, Control Panel, Action Bar
- Advanced tools
  - Watershed, shading, stitching?
History

**ImageJ**: successor of a software from the National Institutes of Health called *NIH Image* (Pascal-based, Mac only, early 90's)
- Developed by Wayne Rasband, started 1997
- Public Domain → source code available
- Java based → Win, Mac, Linux, ...
- Macros & plug-ins
- Huge potential, very active community
- Technical design limitations
  - 15 yrs. old, usability somewhat “aged”

→ ImageJ basically can do everything, it's just sometimes very hard to find out how...
History

*ImageJ* from the technical / administrative view
- Requires a Java runtime installed
- Can update *itself* only
  - Java?
  - Plugins?
- Shipped with small, generic set of Plugins & Macros

*Distributions* showed up to address this:
- **MBF ImageJ** (MacBiophotonics) “IJ for Microscopy”
  - Plugin collection
  - Abandoned
- Since 2007 **Fiji** is the don't-worry, ready-to-run solution!

[http://developer.imagej.net/history](http://developer.imagej.net/history)
FiJi is just ImageJ – Batteries included

FiJi is an ImageJ distribution intended for Life sciences:
- JRE with Java3D included
- Huge set of Plugins, e.g. LOCI Bio-Formats
- Powerful update mechanism
  - Non-intrusive
  - Cares about Java, the Plugins, ...
  - Customizable
- Extensive documentation
- Easy to install
- But: shares ImageJ's limitations

FiJi is actively co-developed with ImageJ2 to reduce redundant work and share good ideas and mechanisms.
FiJi vs. ImageJ continued

ImageJ
- Generic image processing framework - unfocused
- Single “lead” developer W. Rasband

FiJi
- Aimed for Life Sciences
- Emphasis on Registration, Segmentation & Volume Data
- Community development effort
- Quality mechanisms for plugins
  - Interoperability & code checks
  - Proper documentation
  - Maintainers for plugins
- Support for more additional languages: Python, Ruby, ...
- Script editor to develop plugins and macros

→ Use FiJi and add the plugins you need! (e.g. from MBF)
Resources


ImageJ dokuwiki:  http://imagejdocu.tudor.lu/

ImageJ macros:  http://imagej.nih.gov/ij/macros/

ImageJ mailing list:  http://rsb.info.nih.gov/ij/list.html

FiJi download:  http://fiji.sc/wiki/index.php/Downloads

FiJi wiki containing documentation for plugins, tutorials, etc:  http://fiji.sc/wiki/
FiJI – getting started

First installation on Windows:
- Download from http://fiji.sc/
- If possible, use 64bit version
- Choose a writeable location
  - NOT “C:\Program Files\…”!
  - NOT on a network share (works, but slow!)
  - e.g. “D:\Tools”
- Unzip
- Start & run updater
  - …

→ Do NOT use “Update ImageJ” (unless explicitly requested)
# Updating Fiji

Sometimes the updater has a problem, just delete the folder “update” inside the Fiji folder.

![ImageJ Updater](image)

In general, it is safe to just click on “Apply” to install the updates (and new packages).

More information is provided by the “Advanced Mode”...
Updating FiJi - Advanced

ImageJ Updater

Search:

View Options: View all files

Please choose what you want to install/uninstall:

<table>
<thead>
<tr>
<th>Name</th>
<th>Status/Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>scripts/InstallJava3D.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/InstallJava3DInstalled.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/InstallJava3DLibrary.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/InstallJava3DLibraryInstalled.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/InstallJava3DLibraryDemo_1.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/InstallJava3DLibraryDemo_2.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/InstallJava3DLibraryDemo_3.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/InstallJava3DLibraryIntroduction.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/Miji.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/Miji_Test.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/Record_Desktop.py</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/Record_Window.py</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>scripts/bfopen.m</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>images/icon-flat.png</td>
<td>Locally modified</td>
</tr>
<tr>
<td>images/icon.png</td>
<td>Locally modified</td>
</tr>
<tr>
<td>macros/StartupMacros.fiji.ijm</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>macros/listManagement.txt</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>macros/toolsSets/Clear Custom Tools.txt</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>macros/toolsSets/Drawing Tools.txt</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>macros/toolsSets/Lookup Tables.txt</td>
<td>Up-to-date</td>
</tr>
<tr>
<td>luts/16_colors.lut</td>
<td>Up-to-date</td>
</tr>
</tbody>
</table>

install/update: 1 (344.5kB)

Keep as-is  Install  Uninstall  Apply changes  Easy mode  Cancel

Manage update sites  Show changes
Image Types I

Digital Images are tables of intensities, each element defining a local brightness value.

Steps depend on the number of levels used for quantization:
- 1 bit → 0 or 1 → 2 steps
- 2 bit = 2^2 → 4 steps
- 8 bit = 2^8 → 256 steps
- 16 bit = 2^16 = 65536
- 32 bit = 2^32 > 4 million

Special case “RGB” = 8 bit for each, Red Green and Blue (24 bit overall)
Image Types II

ImageJ's handling of image-data evolved over time

- Single (x,y)
- Stack (x,y,c) / (x,y,t)

- Hyperstack: 4D / 5D
  - multi-channel timelapse
  - multiple positions
  - not limited to just 3 channels
  - ...
Colors

Several ways of dealing with colors exist in ImageJ:

- No additional information → greyscale intensities
- Multi-channel with colors assigned
  - “color” mode
  - “composite” mode
- RGB colors are no separated channels!

For visualization, ImageJ provides the option to assign pseudo-colors via LUT (Look-Up-Tables) → see later.
The user interface

The main window has three parts:

- Menu bar
- Tools
- Status line
  - ImageJ & Java version
  - Memory architecture & current usage
  - Pixel positions and intensities while hovering on images
  - Descriptions of toolbar entries
  - ...
Opening Images

Via Menu “File”
- Open / Open Recent
  - TIFF, GIF, JPEG, PNG, DICOM, BMP, PGM, FITS
- Import
  - Sequences, Text Images, URL's, AVI's, LUT's, …

Drag And Drop (on main window)
- Tries to guess the applicable reader (no choice)

Using the Bio-Formats library from the LOCI plugin collection:
- File > Import > Bio-Formats (at the bottom)
- Plugins > LOCI > Bio-Formats Importer

→ Bio-Formats is the preferred way for most proprietary file-formats.
http://loci.wisc.edu/bio-formats/formats
Opening Images with Bio-Formats

![ImageJ/Fiji window showing Bio-Formats Import Options]

**Stack viewing**
- View stack with: Hyperstack
- Stack order: XYCZT

**Metadata viewing**
- Display metadata
- Display OME-XML metadata
- Display ROIs

**Dataset organization**
- Group files with similar names
- Open files individually
- Swap dimensions
- Open all series
- Concatenate series when compatible
- Stitch tiles

**Memory management**
- Use virtual stack
- Specify range for each series
- Crop on import

**Split into separate windows**
- Split channels
- Split focal planes
- Split timepoints

**Color mode** - Visualizes channels according to the specified scheme.

Possible choices are:

- **Default** - Display channels as closely as possible to how they are stored in the file.
- **Composite** - Open as a merged composite image. Channels are colorized according to metadata present in the dataset (if any), or in the following default order: 1=red, 2=green, 3=blue, 4=gray, 5=cyan, 6=magenta, 7=yellow.
- **Colorized** - Open with each channel in a separate plane, colorized according to metadata present in the dataset (if any), or in the default order (see Composite above).
- **Grayscale** - Open with each channel in a separate plane, displayed in grayscale.

[OK] [Cancel]
The image window

Header line showing information:
- Channels
- Slices
- Calibration
- Bit-depth
- Size (in memory!)

Sliders at the bottom to adjust:
- Active channel
- Z-slice
- Timepoint

Status bar in main window shows intensities of current channel.
The Toolbar

Selection Tools:
- Right click: choose variant
- Double click: properties
→ select region(s) of interest

- Text tool
- Zoom & pan
- Colorpicker

User-configurable toolsets
Image calibration

If you plan to do measurements on your images, check the calibration!

Image > Show Info

Image > Properties
Display Settings

Use Image > Adjust > “Brightness / Contrast” to set the display minimum and maximum values.

→ “Auto” allows for a minimal saturation – usually sane setting for human perception.

→ These settings DO NOT alter your data, except when using the “Apply” button.
Color Modes

Use Image > Colors > Channels Tool to select the display mode and change the assignment of colors to the individual channels.
Lookup Tables

LUT's are *filters* that are applied before the image is displayed on the screen.
- Useful to check for saturation
- Emphasize special intensities
- Take B&C settings into account!
- Not available for RGB images.

Image > Lookup Tables
or
Directly from the Toolbar

Characteristics & Editor:
- Image > Color > Show LUT
- Image > Color > Edit LUT
Histogram

Analyze > Histogram

Shows intensities distribution.
- use “Log” mode
- honors LUT
- Statistics
- Interactive
Measuring

ImageJ provides plenty of information for selected regions.
To measure, just press “m” and the selected results will show up in a new window.

→ Types can be configured in Results > Set Measurements
→ can be saved as txt or csv file
**Distance / Profile Plots**

Analyze > Plot Profile shows the intensity profile along a previously selected line.

E.g. useful to measure the diameter of an object for parts above a certain intensity only.

The Plot itself is again an image where, so measurements can be used on it again.
Thresholding

Simplest approach for segmentation:
- Image > Adjust > Threshold
- Choose variant, background and value
- Result is a binary image
Local Thresholding

Image
> Adjust
> Auto Local Threshold

Auto Local Threshold v1.4
Method
Radius
Special parameters (if different from default)
Parameter 1
Parameter 2

☑️ White objects on black background

Thresholded result is always shown in white [255].

OK Cancel
Local Thresholding

Displays results for all local thresholding methods.

→ Try various settings until results are good.

→ Run again and select the desired method instead of “all”.

![Montage image showing results for different local thresholding methods](image-url)
Analyze > Analyze Particles finds connected components in a thresholded (binary) image.

- Results and ROI Manager is shown
ROI Manager

Analyze > Tools > ROI Manager: provides possibilities to handle multiple regions of interest, for example:
- Edit, delete, label
- Save, load to and from files
- Reapply to another image
- Measure
Touching Objects

Use Process > Binary > Watershed to split touching objects in a binary image. Analyze Particles has to be re-run afterwards.
Filtering

Located in Process > Filters

Gaussian Blur

Median

ImageJ / FiJi workshop
3D Viewer
Usability

Plugins > Shortcuts > List Shortcuts...

<table>
<thead>
<tr>
<th>Hot Key</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close Bracket</td>
<td>Show All</td>
</tr>
<tr>
<td>Open Bracket</td>
<td>Script Editor</td>
</tr>
<tr>
<td>1</td>
<td>Select First Lane</td>
</tr>
<tr>
<td>2</td>
<td>Select Next Lane</td>
</tr>
<tr>
<td>3</td>
<td>Plot Lanes</td>
</tr>
<tr>
<td>4</td>
<td>Original Scale</td>
</tr>
<tr>
<td>5</td>
<td>View 100%</td>
</tr>
<tr>
<td>9</td>
<td>*recent commands</td>
</tr>
<tr>
<td>A</td>
<td>Select None</td>
</tr>
<tr>
<td>B</td>
<td>Blobs (25K)</td>
</tr>
<tr>
<td>C</td>
<td>Brightness/Contrast...</td>
</tr>
<tr>
<td>D</td>
<td>Duplicate...</td>
</tr>
<tr>
<td>E</td>
<td>Restore Selection</td>
</tr>
<tr>
<td>F</td>
<td>Flatten</td>
</tr>
<tr>
<td>G</td>
<td>Capture Screen</td>
</tr>
<tr>
<td>H</td>
<td>Orthogonal Views</td>
</tr>
<tr>
<td>I</td>
<td>Invert</td>
</tr>
<tr>
<td>K</td>
<td>Color Picker...</td>
</tr>
<tr>
<td>M</td>
<td>Install...</td>
</tr>
<tr>
<td>N</td>
<td>Text Window</td>
</tr>
<tr>
<td>O</td>
<td>Open Next</td>
</tr>
</tbody>
</table>
Usability

Undo limitations – just ONE step:
- There used to be a “multi undo” option, unfortunately it doesn't show up in recent FiJi / ImageJ versions.
- While generating a work flow for image analysis use the “Duplicate” (Shift-D) command to work on a copy.

While “playing” it is easy to get confused which operations you used, especially when trying to reproduce an intermediate result.
→ The “Recent commands” window shows them in reverse order.
Usability

The LOCI tools provide a “shortcut” window containing buttons for the individual tools – very useful if you need to access them often in your workflow.

Open the window in Plugins > LOCI > LOCI Plugins Shortcut Window
Usability

Instead of navigating through the tedious menus, ImageJ provides the “Control Panel” which shows the complete menu structure in a collapsable tree view – sub-menus stay open and can be undocked for quick access.

Open it via Shift-Ctrl-U or Plugins > Utilities > Control Panel.

A very fast and handy way is to use the command finder. Just press “L” on the keyboard and start typing right away:
Usability

A more sophisticated way to adjust ImageJ to your needs is provided by the “ActionBar” Plugin that creates graphical toolbars with big icons:

While this is a very nice tool it unfortunately doesn't have a nice way to create or modify the Action Bars – this requires manually editing the definition text file of a bar.

Hands-on session